900+ orders shipping 1 day late out of New Lenox, IL warehouse
Resolved
All orders have shipped.
Posted Oct 19, 2017 - 20:55 PDT
Identified
Due to a file transmission error, which is now fixed, 989 orders at the New Lenox, IL warehouse did not ship out on October 18, 2017 as expected. These orders will ship out a day late on Thursday, October 19, 2017 instead.
Posted Oct 18, 2017 - 21:20 PDT
This incident affected: Warehouses (New Lenox, IL).