Some orders from the Tin Shui Wai, HKG warehouse did not ship out on December 6, 2017
Incident Report for Shipwire
Resolved
All impacted orders have been shipped.
Posted 11 months ago. Dec 07, 2017 - 17:52 PST
Identified
A service interuption caused 955 orders to not ship from the Tin Shui Wai, HKG warehouse today.  The root cause has been identified and the impacted orders are expected to ship out tomorrow, December, 7, 2017.
Posted 11 months ago. Dec 06, 2017 - 17:39 PST
This incident affected: Warehouses (Shenzhen, CHN).