Shipping Delays During Chinese New Year and Spring Festival
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted 6 days ago. Mar 12, 2019 - 09:13 PDT
Monitoring
During the week of February 4-8th, please expect delays in shipping from our Shenzhen, CHN warehouse due to Chinese New Year and the Spring Festival. If you have any questions or concerns, please contact customercare@ingrammicroservices.com
Posted about 2 months ago. Jan 24, 2019 - 17:07 PST
This incident affected: Warehouses (Shenzhen, CHN).