Scheduled customer support phone line maintenance - May 19, 2017
Incident Report for Shipwire
Resolved
Our phone line maintenance has been completed.
Posted 6 months ago. May 19, 2017 - 09:59 PDT
Identified
The Ingram Micro Commerce & Fulfillment Solutions customer support phone lines will be down between 6:00AM - 8:00AM PST on Friday May 19, 2017 for scheduled maintenance and testing. Please email customercare@ingrammicrocommerce.com with any inquiries between these hours.
Posted 6 months ago. May 18, 2017 - 13:48 PDT