Hongkong Post International e-Express service unavailble to Australian destinations
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 09:36 PDT
Monitoring
Please be advised that Hongkong Post International e-Express service is on hold until further notice for shipments destined for Australian addresses. Hong Kong Post Int'l registered mail service continues to be an option for these shipments.
Posted Aug 26, 2022 - 10:24 PDT
This incident affected: Carriers (Hong Kong Post).