Daventry, GBR Carrier Service Disruptions
Incident Report for Shipwire
Resolved
DHL Express has resumed package collection operations from our Daventry, GBR facility.
Posted Jan 04, 2021 - 09:34 PST
Monitoring
Please be informed that DHL Express has suspended package collection operations from our Daventry, GBR facility until January 04, 2021. DHL Express out of Daventry will not be available until the carrier has resumed collections. International export services with Royal Mail, Parcelforce, DPD, and ABM remain available, but please expect delays into the EU.

We are keeping a close eye on our carrier partners in the UK and will continue to update you with more information as it comes.
Posted Dec 22, 2020 - 14:12 PST
This incident affected: Warehouses (Daventry, GBR).