DHL Express Service Delays
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted May 05, 2021 - 11:00 PDT
Monitoring
DHL Express is expecting 1+ delays in their network out of their Netherlands facility for orders shipping to the following countries: United Kingdom, Germany, France, Ireland, Spain, Italy, and Turkey.

We will continue to provide updates accordingly.
Posted Apr 20, 2021 - 10:52 PDT
This incident affected: Carriers (DHL Express) and Warehouses (Waalwijk, NLD).