Temporarily Disabled: Parcelforce Euro Priority Business (PF EU)
Incident Report for Shipwire
Resolved
Parcelforce Euro Priority Business (PF EU) is now enabled again.
Posted Sep 01, 2021 - 10:43 PDT
Identified
Effective immediately, August 31, 2021 and until further notice, Parcelforce Euro Priority Business (PF EU) will be temporarily disabled from the Shipwire Platform due to new requirements for the exporters EORI (Economic Operators Registration and Identification Number). We are working on resolving this as quickly as possible.

If you have any questions, please contact your account manager or our Customer Care Team at customercare@ingrammicroservices.com.

Thank you.
Ingram Micro Transportation Team
Posted Aug 31, 2021 - 12:26 PDT
This incident affected: Warehouses (Laughton-Lewes, GBR, Daventry, GBR) and Carriers (Parcel Force).