DHL eComm Services Temporarily on Hold
Incident Report for Shipwire
Resolved
Shipwire has removed the temporary hold on DHL Ecommerce services (DHL Global Mail Lightweight Parcel and Packet Plus International).
Posted Sep 14, 2020 - 12:30 PDT
Monitoring
Dear Valued Customer,

Shipwire has placed a temporary hold on all DHL Ecommerce services (DHL Global Mail Lightweight Parcel and Packet Plus International) until further notice. We are resolving this issue with the carrier and will resume the activities as soon as possible.

Until DHL Ecommerce activities are resumed, the Shipwire Platform will select the next most optimal service for your orders.
Posted Sep 03, 2020 - 14:50 PDT
This incident affected: Carriers (DHL eCommerce (Global Mail)).