Localised Flooding in the Selby, North Yorkshire (UK)
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted Mar 19, 2020 - 07:39 PDT
Monitoring
Due to localised flooding in the Selby area, the below postcodes may experience delivery delays:

DN14
YO8
YO19
YO23
DN7
DN5

Drivers and couriers have been advised not to put themselves at risk and apply adverse weather scans where required.
Posted Mar 02, 2020 - 09:38 PST