UK and Australia Warehouse Closures in Observance of Her Majesty Queen Elizabeth II’s State Funeral
Update
** Update on correct dates:

In observance of Her Majesty Queen Elizabeth II’s State Funeral, our UK and Australia facilities will be closed on the following dates:

Daventry and Laughton Lewes, United Kingdom - September 19, 2022
Eastern Creek, Australia - September 22, 2022
Posted Sep 13, 2022 - 15:25 PDT
Identified
In observance of Her Majesty Queen Elizabeth II’s State Funeral, our UK and Australia facilities will be closed on the following dates:

Daventry and Laughton Lewes, United Kingdom - September 19, 2022
Eastern Creek, Australia - September 22, 2022
Posted Sep 13, 2022 - 09:11 PDT
This incident affects: Warehouses (Laughton-Lewes, GBR, Eastern Creek, AUS, Daventry, GBR).