Customer Support Delays due to COVID-19
Incident Report for Shipwire
Resolved
In an effort to help support our customers, we are reopening our customer service phone lines. You can reach our customer care team at 1-888-744-7947. Please note that wait times may be longer than normal. You can also continue contacting our customer care team via email at customercare@ingrammicroservices.com.
Posted Jul 14, 2020 - 10:06 PDT
Update
We are continuing to monitor for any further issues.
Posted May 14, 2020 - 07:41 PDT
Monitoring
Due to the evolving COVID-19 situation and in compliance with local ordinances, our Customer Care Team workforce is temporarily limited and you may experience some delays as our team works through heavy volume. Our Customer Care Team is working through priority requests. We appreciate your patience during this time.
Posted Mar 16, 2020 - 12:08 PDT
This incident affected: Warehouses (Redlands, CA, Mira Loma, CA, Carrollton, TX, Millington, TN, Carol Stream, IL, New Lenox, IL, Lancaster, PA, Jonestown, PA, Tilburg, NLD, Laughton-Lewes, GBR, Shenzhen, CHN, Mississauga, CAN, Richmond, CAN, Eastern Creek, AUS, Hermosa, CA, Daventry, GBR, Waalwijk, NLD).