Rialto, CA Fulfillment Center Closure
Incident Report for Shipwire
Resolved
The Rialto, CA facility is back operating today as planned. We're still working through a backlog of orders but plan to be fully caught up by Wednesday. Thank you for your patience and understanding.
Posted Aug 01, 2022 - 13:43 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 28, 2022 - 09:31 PDT
Identified
Please be advised that our Rialto, California fulfillment center is closing today, July 28th, and tomorrow, July 29th due to COVID-19 impacting the operations team. We will be conducting a deep sanitization of the facility over the weekend and plan on re-opening on Monday, August 1st. Please expect fulfillment delays.
Posted Jul 28, 2022 - 09:27 PDT
This incident affected: Warehouses (Rialto, CA).