Typhoon Mangkhut Causing Delays in Southeast Asia and China
Resolved
This incident has been resolved.
Posted Sep 28, 2018 - 11:38 PDT
Identified
Typhoon Mangkhut has caused a path of destruction in Southeast Asia and made landfall China late afternoon on Sunday, September 16th.

As a result, our Shenzhen, CHN warehouse will be closed Monday, September 17th due to the typhoon. We anticipate the warehouse will be open Tuesday, September 18th, however, we will update you if the weather conditions continue and we have to close the warehouse on Tuesday.
Posted Sep 17, 2018 - 05:01 PDT
This incident affected: Warehouses (Shenzhen, CHN).