UPS Service Delays due to Severe Weather
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted Apr 26, 2021 - 09:27 PDT
Investigating
Due to severe weather, UPS service delays are expected in certain areas. The impacted zip codes in Wyoming are as follows: 82301, 82310, 82321, 82322, 82323, 82324, 82325, 82327, 82329, 82331, 82332, 82334, 82335, 82336.

We are monitoring the situation and will continue to provide updates.
Posted Apr 16, 2021 - 09:02 PDT
This incident affected: Carriers (UPS).