Hurricane Dorian impacting mail delivery services in the southeast United States
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted Dec 05, 2019 - 14:56 PST
Identified
Mail delivery services with FedEx, UPS, and USPS are disrupted in areas impacted by Hurricane Dorian in North Carolina, South Carolina, Florida, and Georgia. If you have packages destinations in areas impacted by the hurricane, please expect delivery delays. For questions or concerns please contact customercare@ingrammicroservices.com
Posted Sep 03, 2019 - 15:42 PDT
This incident affected: Carriers (FedEx, UPS, USPS).