Reno, Nevada - Snow Storm Causing Delays
Resolved
This incident has been resolved.
Posted Jan 18, 2023 - 01:47 PST
Monitoring
Please be advised that order fulfillment may be delayed this week from our Reno, Nevada facility due to snow storms this week. You may experience delays in fulfillment processing and increased transit times due to the current inclement weather and extended forecast through Thursday, January 5th.
Posted Jan 03, 2023 - 00:20 PST
This incident affected: Warehouses (Reno, NV).