July Fuel Surcharge update - Passport, DPD and Parcelforce
Resolved
This incident has been resolved.
Posted Jul 05, 2022 - 08:58 PDT
Identified
Starting on July 1, 2022, the below carriers will be adjusting fuel surcharges due to the rise in domestic fuel costs.

Passport (from the U.S.)
Fuel surcharge by destination country:
Region $/LB Surcharge
Canada $0.418
Australia $0.763
United Kingdom $0.708
Western Europe $0.806
Rest of World $0.908

DPD (from the U.K.)
The fuel surcharge will increase from 13.5% to 14%.

Parcelforce (from the U.K.)
The fuel surcharge will increase from 13% to 15% for domestic services only.
Posted Jun 20, 2022 - 09:12 PDT
This incident affected: Carriers (DPD, Parcel Force).